
Exercise : 1 

 

Title: Variable View and Data View in SPSS 

Aim: 
To learn the process of defining variables in Variable View and entering data in Data View in 

SPSS. 

 

Procedure: 

1. Step 1: Launching SPSS 
Open the SPSS software by selecting it from the program list or desktop. 

2. Step 2: Defining Variables in Variable View 
o Go to the Variable View tab. 

o For each variable, complete the following: 

 Name: Enter a short, descriptive name (e.g., "Income," "Education"). 

 Type: Choose the appropriate data type (Numeric or String). 

 Width: Adjust the width (default is often appropriate). 

 Decimals: Set the number of decimal points (relevant for numeric 

variables). 

 Label: Provide a full descriptive label for better understanding (e.g., 

"Monthly Income"). 

 Values: Input values for categorical variables (e.g., 1 = Yes, 2 = No). 

 Missing: Assign any codes for missing data if required. 

 Measure: Choose whether the variable is Nominal, Ordinal, or Scale. 

3. Step 3: Entering Data in Data View 
o Click on the Data View tab. 

o Enter your dataset row by row, where: 

 Each row represents an individual case or observation. 

 Each column corresponds to a variable defined in Variable View. 

4. Step 4: Saving the File 
o Click File and then Save As. 

o Choose the location to save the file. 

o Enter an appropriate name for the file and click Save. 

 

Summary: 
Variables are set up in Variable View with appropriate attributes, and data is entered in Data 

View for analysis. Finally, the dataset is saved for future use. 

 

 

 



Exercise : 2 

 

Title: Table Creation in SPSS 

Objective: 
To create and interpret a table in SPSS for analyzing data. 

 

Procedure: 

1. Step 1: Open SPSS 
Launch SPSS and open the dataset you wish to analyze. 

2. Step 2: Creating a Frequency Table 
o Click on Analyze in the menu bar. 

o Select Descriptive Statistics → Frequencies. 

o In the dialog box, move the variable(s) you want a table for into the 

Variable(s) box. 

o Click OK to generate a frequency table. 

3. Step 3: Creating a Crosstab Table 
o Go to Analyze → Descriptive Statistics → Crosstabs. 

o Move the desired variable to the Rows and another variable to the Columns. 

o Click OK to create the crosstab table. 

4. Step 4: Save the Table Output 
o After the table appears in the output window, click File → Save As to save the 

output. 

 

Example of a Common Table: 

Age Group Frequency Percentage 

18-25 50 25% 

26-35 80 40% 

36-45 45 22.5% 

46+ 25 12.5% 

 

Conclusion: 
The table summarizes the distribution of data in SPSS using frequency or crosstab functions. 

 
 

 

 

 



Exercise : 3 

 

Title: Measures of Central Tendency in SPSS 

Objective: 
To compute and interpret the measures of central tendency: Mean, Median, and Mode in 

SPSS. 

 

Procedure: 

1. Step 1: Open SPSS 
Start SPSS and load your dataset. 

2. Step 2: Access Descriptive Statistics 
o Click Analyze → Descriptive Statistics → Frequencies or Descriptives. 

o Select the variable(s) for which you want to calculate central tendency. 

3. Step 3: Calculate Mean, Median, and Mode 
o In the Frequencies dialog box: 

 Click Statistics. 

 Check Mean, Median, and Mode. 

 Click Continue → OK to generate the output. 

4. Step 4: Interpret the Results 
o Mean: The average value of the dataset. 

o Median: The middle value when data is arranged in order. 

o Mode: The most frequently occurring value in the dataset. 

 

Example Output: 

Measure Value 

Mean 25.6 

Median 24.0 

Mode 22.0 

 

Conclusion: 
The measures of central tendency help summarize a dataset's average, middle, and most 

frequent values. 

 

 

 



Exercise : 4 

 

Title: Creating Charts and Graphs in SPSS 

Objective: 
To create and interpret common charts and graphs in SPSS. 

 

Procedure: 

1. Open SPSS 
Launch the SPSS software and open your dataset. 

2. Create a Bar Chart 
o Path: Graphs → Chart Builder 

o Drag the Bar chart type to the chart preview area. 

o Move the variable to the Category Axis and another variable to the Bar 

Representations. 

o Click OK to generate the bar chart. 

3. Create a Histogram 
o Path: Graphs → Chart Builder 

o Drag the Histogram chart type to the chart preview area. 

o Move the variable to the X-Axis. 

o Click OK to generate the histogram. 

4. Create a Pie Chart 
o Path: Graphs → Chart Builder 

o Select the Pie chart type and drag it to the chart preview area. 

o Move the variable to the Slice By box. 

o Click OK to generate the pie chart. 

5. Save the Chart 
o Right-click on the chart in the output window. 

o Select Export or Save As to save the chart. 

 

Conclusion: 
Charts and graphs in SPSS help visualize data, making patterns and relationships clearer. 

 

 

 

 

 



Exercise : 5 

 

Title: One-Sample T-Test in SPSS 

Objective: 
To perform a one-sample t-test in SPSS to compare the sample mean against a known value. 

 

Procedure: 

1. Open SPSS 
Launch SPSS and open your dataset. 

2. Access One-Sample T-Test 
o Path: Analyze → Compare Means → One-Sample T Test 

3. Set Up the Test 
o Move the variable you want to test into the Test Variable(s) box. 

o Enter the known value (the hypothesized mean) into the Test Value box. 

4. Run the Test 
o Click OK to perform the t-test. 

5. Interpret the Output 
o Review the t-test results in the output window, including: 

 T Value: The calculated t statistic. 

 Degrees of Freedom (df): Number of observations minus 1. 

 Sig. (2-tailed): The p-value indicating the probability of the observed 

result under the null hypothesis. 

 

Example Output: 

Test Variable Mean Test Value T Value df Sig. (2-tailed) 

Variable X 20.5 18 3.15 29 0.004 

 

Conclusion: 
The one-sample t-test compares the sample mean to a known value, providing a t statistic and 

p-value to assess if the sample mean significantly differs from the hypothesized mean. 

 

 

 

Exercise : 6 



 

Title: One-Way ANOVA in SPSS 

Objective: 
To perform a one-way ANOVA in SPSS to compare the means of three or more groups. 

 

Procedure: 

1. Open SPSS 
Launch SPSS and open your dataset. 

2. Access One-Way ANOVA 
o Path: Analyze → Compare Means → One-Way ANOVA 

3. Set Up the ANOVA 
o Move the dependent variable (the variable you are comparing) into the 

Dependent List box. 

o Move the independent variable (the grouping variable) into the Factor box. 

4. Configure Options 
o Click Post Hoc if you want to perform post hoc tests (optional, for comparing 

all pairs of groups). 

o Choose appropriate post hoc tests (e.g., Tukey, Bonferroni) if needed. 

o Click Options to select additional statistics (e.g., Means, Standard Deviations). 

5. Run the Test 
o Click OK to perform the one-way ANOVA. 

6. Interpret the Output 
o ANOVA Table: Review the F-value and p-value to determine if there are 

significant differences between group means. 

o Post Hoc Tests: If applicable, review the results to see which specific groups 

differ. 

 

Example Output: 

Source Sum of Squares df Mean Square F Value Sig. 

Between Groups 150.25 2 75.125 5.67 0.007 

Within Groups 523.50 27 19.37   

Total 673.75 29    

 

Conclusion: 
One-way ANOVA compares the means of multiple groups to determine if at least one group 

mean is significantly different from the others. Post hoc tests can be used to identify which 

groups differ.

 



Exercise : 7 

 

Title: Mann-Whitney U Test in SPSS 

Objective: 
To perform the Mann-Whitney U test in SPSS to compare differences between two 

independent groups on a continuous or ordinal dependent variable. 

 

Procedure: 

1. Open SPSS 
Launch SPSS and open your dataset. 

2. Access Mann-Whitney U Test 
o Path: Analyze → Nonparametric Tests → Legacy Dialogs → 2 Independent 

Samples 

3. Set Up the Test 
o Move the dependent variable (the variable being compared) into the Test 

Variable List box. 

o Move the grouping variable (the variable defining the two groups) into the 

Grouping Variable box. 

o Click Define Groups and enter the values that represent the two groups in the 

Group 1 and Group 2 fields. 

4. Run the Test 
o Click OK to perform the Mann-Whitney U test. 

5. Interpret the Output 
o Mann-Whitney U: Review the U statistic for differences between groups. 

o Asymp. Sig. (2-tailed): The p-value indicating whether the differences are 

statistically significant. 

 

Example Output: 

Group N Mean Rank Sum of Ranks 

Group 1 30 35.75 1072.50 

Group 2 30 25.25 757.50 

Test Statisticsa Mann-Whitney U Wilcoxon W Z Asymp. Sig. (2-tailed) 

 315.50 757.50 -2.30 0.021 

 

Conclusion: 
The Mann-Whitney U test assesses whether there is a significant difference between the 



distributions of two independent groups. The p-value indicates if the observed differences are 

statistically significant. 

 

 

 

 

 

 

Exercise : 8 

 

Title: Friedman’s Test in SPSS 

Objective: 
To perform Friedman's test in SPSS to compare the medians of three or more related groups. 

 

Procedure: 

1. Open SPSS 
Launch SPSS and open your dataset. 

2. Access Friedman's Test 
o Path: Analyze → Nonparametric Tests → Legacy Dialogs → K Related 

Samples 

3. Set Up the Test 
o Move the variables representing the related groups into the Test Variables List 

box. 

o Ensure that these variables are paired observations (e.g., measurements taken 

at different times or conditions). 

4. Run the Test 
o Click OK to perform Friedman's test. 

5. Interpret the Output 
o Friedman’s Chi-Square: Review the chi-square statistic to assess if there are 

significant differences between the medians of the groups. 

o Asymp. Sig.: The p-value indicating whether the differences in medians are 

statistically significant. 

 

Example Output: 



Test Statisticsa Chi-Square df Asymp. Sig. 

 10.75 2 0.005 

Ranks Table: 

Variable Mean Rank 

Condition 1 2.85 

Condition 2 1.75 

Condition 3 3.40 

 

Conclusion: 
Friedman’s test evaluates if there are significant differences in median values across three or 

more related groups. The p-value indicates if the differences are statistically significant. 

 

 

 

 

 

 

 

Exercise : 9 

 

Title: Kruskal-Wallis Test in SPSS 

Objective: 
To perform the Kruskal-Wallis H test in SPSS to compare the medians of three or more 

independent groups. 

 

Procedure: 

1. Open SPSS 
Launch SPSS and open your dataset. 

2. Access Kruskal-Wallis Test 



o Path: Analyze → Nonparametric Tests → Legacy Dialogs → K Independent 

Samples 

3. Set Up the Test 
o Move the dependent variable (the variable being compared) into the Test 

Variable List box. 

o Move the grouping variable (the variable defining the groups) into the 

Grouping Variable box. 

o Click Define Range and enter the range of values that represent the groups. 

4. Run the Test 
o Click OK to perform the Kruskal-Wallis test. 

5. Interpret the Output 
o Kruskal-Wallis H: Review the H statistic to assess if there are significant 

differences between the medians of the groups. 

o Asymp. Sig.: The p-value indicating whether the differences in medians are 

statistically significant. 

 

Example Output: 

Test Statisticsa Chi-Square df Asymp. Sig. 

 15.23 3 0.002 

Ranks Table: 

Group N Mean Rank 

Group 1 30 22.75 

Group 2 30 29.50 

Group 3 30 18.25 

 

Conclusion: 
The Kruskal-Wallis test assesses whether there are significant differences in the median 

values across three or more independent groups. The p-value indicates if the differences are 

statistically significant. 

 

 

 

Exercise : 10 



 

Title: Creation of Company in Tally Prime 

Objective: 
To set up a new company in Tally Prime efficiently. 

 

Procedure: 

1. Open Tally Prime 
Launch Tally Prime on your computer. 

2. Navigate to Company Creation 
o Path: Gateway of Tally → Company Info → Create Company 

o Shortcut: Press Alt + F3 to directly access the Company Info menu. 

3. Enter Company Details 
o Name: Enter the company name. 

o Address: Fill in the company address and contact details. 

o Financial Year: Set the financial year starting date. 

o Currency: Select the appropriate currency. 

o State: Choose the state for GST compliance. 

4. Save the Company 
o Click Accept (or press Ctrl + A) to save and create the company. 

5. Confirm Company Creation 
o Ensure the company details are correct and the company is now listed in the 

company list. 

 

Conclusion: 
Creating a company in Tally Prime is a straightforward process, allowing for efficient setup 

with direct shortcuts for quick access. 

 

 

 

 

 

 

 

Exercise : 11 



 

Title: Creating Accounting Groups 

Objective: 
To set up accounting groups in Tally Prime for organizing and managing financial 

transactions. 

 

Procedure: 

1. Open Tally Prime 
Launch Tally Prime on your computer. 

2. Navigate to Accounting Groups 
o Path: Gateway of Tally → Accounts Info → Groups → Create 

o Shortcut: Press Alt + A to access the Accounts Info menu, then G to select 

Groups, and C to create a new group. 

3. Enter Group Details 
o Group Name: Enter the name of the new group. 

o Under: Select the appropriate parent group (e.g., Assets, Liabilities) for 

classification. 

o Nature of Group: Specify if it's a primary or sub-group (e.g., Bank Account, 

Fixed Assets). 

4. Set Additional Options 
o Use for: Indicate if the group is used for specific purposes such as GST, 

Interest, etc. 

o Pre-Fill: Optionally, fill in any default values or additional details as required. 

5. Save the Group 
o Click Accept (or press Ctrl + A) to save and create the group. 

6. Confirm Group Creation 
o Verify that the new group is listed under the selected parent group in the group 

list. 

 

Conclusion: 
Creating accounting groups in Tally Prime helps in organizing financial transactions 

efficiently, providing better management and reporting. 

 

 

 

 

Exercise : 12 



 

Title: Creating Ledgers  

Objective: 
To set up new ledgers in Tally Prime for recording specific financial transactions. 

 

Procedure: 

1. Open Tally Prime 
Launch Tally Prime on your computer. 

2. Navigate to Ledger Creation 
o Path: Gateway of Tally → Accounts Info → Ledgers → Create 

o Shortcut: Press Alt + A to access the Accounts Info menu, then L to select 

Ledgers, and C to create a new ledger. 

3. Enter Ledger Details 
o Ledger Name: Enter the name of the new ledger (e.g., Supplier Name, 

Customer Account). 

o Under: Select the appropriate group under which this ledger should be 

classified (e.g., Sundry Creditors, Sales Accounts). 

o Opening Balance: Enter the opening balance if applicable. 

o Maintain Balance: Specify whether to maintain balance or not, depending on 

ledger type. 

4. Set Additional Options 
o Address: (Optional) Enter the address details for the ledger. 

o PAN/TAN: (Optional) Enter PAN/TAN details if applicable. 

o Email/Contact: (Optional) Enter contact information if needed. 

5. Save the Ledger 
o Click Accept (or press Ctrl + A) to save and create the ledger. 

6. Confirm Ledger Creation 
o Verify that the new ledger appears in the ledger list under the appropriate 

group. 

 

Conclusion: 
Creating ledgers in Tally Prime allows for detailed recording of individual transactions and 

accounts, enhancing financial management and reporting accuracy. 

 

 

 

 

Exercise : 13 



 

Title: Creating Vouchers in Tally Prime 

Objective: 
To record financial transactions using vouchers in Tally Prime. 

 

Procedure: 

1. Open Tally Prime 
Launch Tally Prime on your computer. 

2. Navigate to Voucher Creation 
o Path: Gateway of Tally → Vouchers 

o Shortcut: Press V to access the Vouchers menu directly. 

3. Select the Voucher Type 
o Choose the appropriate voucher type for your transaction from the list (e.g., 

Payment, Receipt, Journal, Sales, Purchase). 

o Shortcut: Press F7 for Payment, F6 for Receipt, F5 for Journal, F8 for Sales, 

and F9 for Purchase. 

4. Enter Voucher Details 
o Date: Enter the transaction date. 

o Voucher Number: (Optional) Enter or modify the voucher number. 

o Party Details: Select or enter the ledger accounts involved in the transaction. 

o Amount: Enter the amount for each entry. 

o Narration: (Optional) Add a brief description of the transaction. 

5. Verify Entries 
o Ensure that all entries and amounts are correct. 

6. Save the Voucher 
o Click Accept (or press Ctrl + A) to record the voucher. 

7. Confirm Voucher Creation 
o Verify that the voucher appears in the list of vouchers and reflects in the 

respective accounts. 

 

Conclusion: 
Creating vouchers in Tally Prime enables precise recording of financial transactions, 

supporting accurate bookkeeping and financial reporting. 

 

 

 

 

Exercise : 14 



 

Title: Displaying Trial Balance and Profit & Loss Account 

Objective: 
To view the Trial Balance and Profit & Loss Account reports in Tally Prime. 

 

Procedure: 

Displaying Trial Balance 

1. Open Tally Prime 
Launch Tally Prime on your computer. 

2. Navigate to Trial Balance 
o Path: Gateway of Tally → Display → Trial Balance 
o Shortcut: Press Alt + D to access the Display menu, then T to select Trial Balance. 

3. Select the Period 
o Choose the desired period for which you want to view the Trial Balance. 
o You can set the date range or select a predefined period. 

4. View Trial Balance 
o Review the Trial Balance report showing all ledger balances. 

5. Save or Print (Optional) 
o Use the options to save or print the report if needed. 

 

Displaying Profit & Loss Account 

1. Open Tally Prime 
Launch Tally Prime on your computer. 

2. Navigate to Profit & Loss Account 
o Path: Gateway of Tally → Display → Profit & Loss A/c 
o Shortcut: Press Alt + D to access the Display menu, then P to select Profit & Loss A/c. 

3. Select the Period 
o Choose the period for which you want to view the Profit & Loss Account. 
o You can set the date range or select a predefined period. 

4. View Profit & Loss Account 
o Review the Profit & Loss Account report, which shows the financial performance for 

the selected period. 

5. Save or Print (Optional) 
o Use the options to save or print the report if needed. 

 

 

Conclusion: 
Displaying the Trial Balance and Profit & Loss Account in Tally Prime provides essential 

insights into the financial health and performance of a business. 



 

 

 

 

Exercise : 15 

 

Title: Displaying Balance Sheet 

Objective: 
To view the Balance Sheet report in Tally Prime, summarizing the financial position of the 

company. 

 

Procedure: 

1. Open Tally Prime 
Launch Tally Prime on your computer. 

2. Navigate to Balance Sheet 
o Path: Gateway of Tally → Display → Balance Sheet 

o Shortcut: Press Alt + D to access the Display menu, then B to select Balance 

Sheet. 

3. Select the Period 
o Choose the period for which you want to view the Balance Sheet. 

o Set the date range or select a predefined period to reflect the company’s 

financial position at a specific date. 

4. View Balance Sheet 
o Review the Balance Sheet report, which displays the company's assets, 

liabilities, and equity. 

5. Save or Print (Optional) 
o Use the options to save or print the report if needed. 

 

Conclusion: 
The Balance Sheet in Tally Prime provides a snapshot of a company’s financial position at a 

given point in time, helping assess its financial stability and structure. 

 
 

Exercise : 16 

 



Title: Creating Stock Group 

Objective: 
To organize inventory items by creating stock groups in Tally Prime for better management 

and classification. 

 

Procedure: 

1. Open Tally Prime 
Launch Tally Prime on your computer. 

2. Navigate to Stock Group Creation 
o Path: Gateway of Tally → Inventory Info → Stock Groups → Create 

o Shortcut: Press Alt + G to access the Inventory Info menu, then G to select 

Stock Groups, and C to create a new group. 

3. Enter Stock Group Details 
o Stock Group Name: Enter the name of the stock group (e.g., Electronics, 

Stationery). 

o Under: Choose if this is a primary group or belongs to another group. 

o Should Quantities of Items be Added: Choose Yes if the stock group 

requires the sum of quantities. 

4. Save the Stock Group 
o Click Accept (or press Ctrl + A) to save and create the stock group. 

5. Confirm Stock Group Creation 
o Verify that the newly created stock group appears in the list under Inventory 

Info. 

 

Conclusion: 
Creating stock groups in Tally Prime allows for structured inventory management by 

categorizing items, making stock management easier and more organized. 

 

 

 

 

 

 

Exercise : 17 

 



Title: Viewing Invoice Report with GST in Tally Prime 

Objective: 
To view and analyze the invoice report along with GST details in Tally Prime. 

 

Procedure: 

1. Open Tally Prime 
Launch Tally Prime on your computer. 

2. Navigate to Display Invoice Reports 
o Path: Gateway of Tally → Display More Reports → Statutory Reports → 

GST → GSTR-1 

o Shortcut: Press Alt + G to access Display More Reports, then select Statutory 

Reports, followed by GST and GSTR-1. 

3. Select the Period 
o Choose the time period for which you want to view the invoice report 

(monthly, quarterly, etc.). 

o Set the date range or select a predefined period to display GST invoices. 

4. View GST Invoice Report 
o The report will display all invoices with details like taxable value, GST 

amount, and total value. 

o You can filter the report by B2B, B2C, export invoices, etc. 

5. Verify the GST Details 
o Check if all the necessary GST details are correctly captured, such as GSTIN, 

invoice number, and tax breakup. 

6. Save or Print (Optional) 
o Use the options to save or print the report if needed. 

 

Conclusion: 
Viewing the invoice report with GST in Tally Prime ensures compliance with tax regulations 

and helps in keeping track of GST-related transactions. 

 

 


